Fix mysql2 "Incorrect MySQL client library version! This gem was compiled for..."

After updating my mysql install on I got the following error: "Incorrect MySQL client library version! This gem was compiled for 5.5.15 but the client library is 5.6.10."

Google searches on the problem yielded advice to reinstall the gem using an assortment of flags such as:

  ARCHFLAGS="-arch x86_64" gem install mysql2 -- –with-mysql-config=/usr/local/bin/mysql_config

This did not help.

Next mysql, rbenv, and gems were all removed and reinstalled several times to no avail.

SOLUTION that finally worked:

  $ rm -rf your_app_root/vendor/bundle your_app_root/vendor/cache your_app_root/bin/
  $ bundle install

The fix ended up being quite easy

blog comments powered by Disqus